<!DOCTYPE html><html lang=en-US><head ><link rel=stylesheet href=https://photographylife.com/wp-content/cache/minify/f48b3.single-reviews.include.a6b4ca.css media=all><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"> <script>var ajaxurl='https://photographylife.com/wp-admin/admin-ajax.php';</script> <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1'><title>Arca Swiss Quick Link Set Review - Photography Life</title><link rel=canonical href=https://photographylife.com/reviews/arca-swiss-quick-link-set><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="Arca Swiss Quick Link Set Review - Photography Life"><meta property="og:description" content="Arca Swiss’s “Quick Link Set” is a duo of lightweight plates that go between your tripod and your tripod head, letting you attach and detach the head quickly. I’ve been using the Quick Link Set recently and wanted to cover my impressions in today&#039;s review."><meta property="og:url" content="https://photographylife.com/reviews/arca-swiss-quick-link-set"><meta property="og:site_name" content="Photography Life"><meta property="article:publisher" content="https://www.facebook.com/photographylifeblog"><meta property="article:modified_time" content="2021-10-06T18:03:33+00:00"><meta property="og:image" content="https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Thumbnail.jpg"><meta property="og:image:width" content="2048"><meta property="og:image:height" content="1226"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:site" content="@KillerPhotoTips"><meta name="twitter:label1" content="Est. reading time"><meta name="twitter:data1" content="9 minutes"> <script type=application/ld+json class=yoast-schema-graph>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</script> <link rel=alternate type=application/rss+xml title="Photography Life &raquo; Feed" href=https://photographylife.com/feed> <script id=qc-choice-js-extra>var choice_cmp_config={"utid":"CKeMjUAS2tuh2","enabled":"all","ccpa":"","datalayer":""};</script> <script src=https://photographylife.com/wp-includes/js/jquery/jquery.min.js id=jquery-core-js></script> <link rel=https://api.w.org/ href=https://photographylife.com/wp-json/ ><link rel=alternate type=application/json+oembed href="https://photographylife.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphotographylife.com%2Freviews%2Farca-swiss-quick-link-set"><link rel=alternate type=text/xml+oembed href="https://photographylife.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fphotographylife.com%2Freviews%2Farca-swiss-quick-link-set&#038;format=xml"><style>img#wpstats{display:none}</style><meta name="msapplication-TileColor" content="#2d89ef"><meta name="theme-color" content="#ffffff"> <script async src="https://www.googletagmanager.com/gtag/js?id=UA-5483678-1"></script> <script>window.dataLayer=window.dataLayer||[];function gtag(){dataLayer.push(arguments);}
gtag("js",new Date());gtag("config","UA-5483678-1");</script><script data-cfasync=false>var freestar=freestar||{};freestar.hitTime=Date.now();freestar.queue=freestar.queue||[];freestar.config=freestar.config||{};freestar.debug=window.location.search.indexOf("fsdebug")===-1?false:true;freestar.config.enabled_slots=[];!function(a,b){var c=b.getElementsByTagName("script")[0],d=b.createElement("script"),e="https://a.pub.network/photographylife";e+=freestar.debug?"/qa/pubfig.min.js":"/pubfig.min.js",d.async=!0,d.src=e,c.parentNode.insertBefore(d,c)}(window,document);freestar.initCallback=function(){(freestar.config.enabled_slots.length===0)?freestar.initCallbackCalled=false:freestar.newAdSlots(freestar.config.enabled_slots)}</script> <style>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</style><link rel=icon href=https://photographylife.com/wp-content/uploads/2020/04/cropped-PL-Logo-32x32.png sizes=32x32><link rel=icon href=https://photographylife.com/wp-content/uploads/2020/04/cropped-PL-Logo-192x192.png sizes=192x192><link rel=apple-touch-icon href=https://photographylife.com/wp-content/uploads/2020/04/cropped-PL-Logo-180x180.png><meta name="msapplication-TileImage" content="https://photographylife.com/wp-content/uploads/2020/04/cropped-PL-Logo-270x270.png"><link rel=preload href=/wp-content/plugins/quantcast-choice/public/js/script.min.js as=script><link rel=preload href=/wp-includes/js/jquery/jquery.min.js as=script></head><body class="reviews-template-default single single-reviews postid-242854 header-image content-sidebar genesis-breadcrumbs-visible genesis-footer-widgets-visible"><div class=site-container><header class=site-header><div class=wrap><div class=title-area><p class=site-title><a href=https://photographylife.com/ >Photography Life</a></p><p class=site-description>PL provides various digital photography news, reviews, articles, tips, tutorials and guides to photographers of all levels</p></div><div class="widget-area header-widget-area"><section id=search-2 class="widget widget_search"><div class=widget-wrap><form method=get class="searchform search-form" action=https://photographylife.com/gsearch ><input type=text value=Search... name=q Search... class="s search-input" onfocus="if (this.value == 'Search...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search...';}"><input type=submit class="searchsubmit search-submit" value></form></div></section><section id=text-3 class="widget widget_text"><div class=widget-wrap><div class=textwidget><div class=pl-social><ul> <li><a class="feed bt" title="Read us on your favorite reader" href=https://photographylife.com/feed target=_blank rel="noopener noreferrer"></a></li> <li><a class="facebook bt" title="Follow us on Facebook" href=https://www.facebook.com/photographylifeblog target=_blank rel="nofollow noopener noreferrer"></a></li> <li><a class="twitter bt" title="Follow us on Twitter" href=https://twitter.com/KillerPhotoTips target=_blank rel="nofollow noopener noreferrer"></a></li> <li><a class="youtube bt" title="Visit our YouTube channel" href=https://www.youtube.com/channel/UCjgg6xqjLd65lNC7MWNs9OA target=_blank rel="nofollow noopener noreferrer"></a></li> <li><a class="instagram bt" title="Visit our Instagram page" href=https://www.instagram.com/photographylifeblog/ target=_blank rel="nofollow noopener noreferrer"></a></li></ul></div></div></div></section></div></div></header><nav class=nav-primary aria-label=Main><ul id=menu-main-links class="menu genesis-nav-menu menu-primary js-superfish"><li id=menu-item-237851 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-237851"><a href=/photography-life-reviews><span >Reviews</span></a></li> <li id=menu-item-241987 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241987"><a href=https://photographylife.com/learn-photography><span >Learn</span></a></li> <li id=menu-item-146061 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-146061"><a title="About Us" href=https://photographylife.com/about-us><span >About Us</span></a></li> <li id=menu-item-176150 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-176150"><a href=https://forum.photographylife.com><span >Forum</span></a></li> <li id=menu-item-152205 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152205"><a title=Search href=/pl-search><span >Search</span></a></li></ul></nav><div class=banner_ad><div class=header_ad id=PhotographyLife_970x250_970x90_728x90_320x50_ATF> <script data-cfasync=false>freestar.config.enabled_slots.push({placementName:"PhotographyLife_970x250_970x90_728x90_320x50_ATF",slotId:"PhotographyLife_970x250_970x90_728x90_320x50_ATF"});</script> </div></div><div class=site-container-wrap><div class=site-inner><div class=content-sidebar-wrap><main class=content><div class=breadcrumb><span><span><a href=https://photographylife.com/ >Home</a> → <span><a href=https://photographylife.com/reviews>Reviews</a> → <span><a href=https://photographylife.com/category/accessories>Camera Gear Accessories</a></span></div><article class="post-242854 reviews type-reviews status-publish has-post-thumbnail category-accessories tag-camera-accessories tag-gear-reviews tag-product-reviews tag-tripod-heads tag-tripods entry" aria-label="Arca Swiss Quick Link Set Review"><header class=entry-header><h1 class="entry-title">Arca Swiss Quick Link Set</h1><div class=pl-social-post><ul> <li><a class="facebook bt" title="Share on Facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fphotographylife.com%2Freviews%2Farca-swiss-quick-link-set&t=Arca+Swiss+Quick+Link+Set+Review" target=_blank rel="nofollow noopener noreferrer"></a></li> <li><a class="twitter bt" title="Share on Twitter" href="https://twitter.com/intent/tweet?via=KillerPhotoTips&text=Arca+Swiss+Quick+Link+Set+Review&url=https%3A%2F%2Fphotographylife.com%2Freviews%2Farca-swiss-quick-link-set" target=_blank rel="nofollow noopener noreferrer"></a></li> <li><a class="pinterest bt" title="Share on Pinterest" href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fphotographylife.com%2Freviews%2Farca-swiss-quick-link-set&media=https%3A%2F%2Fphotographylife.com%2Fwp-content%2Fuploads%2F2021%2F10%2FArca-Swiss-Quick-Link-Set-Thumbnail.jpg&description=Arca+Swiss+Quick+Link+Set+Review" target=_blank rel="nofollow noopener noreferrer"></a></li> <li><a class="reddit bt" title="Share on Reddit" href="https://www.reddit.com/submit?url=https%3A%2F%2Fphotographylife.com%2Freviews%2Farca-swiss-quick-link-set&title=Arca+Swiss+Quick+Link+Set+Review" target=_blank rel="nofollow noopener noreferrer"></a></li></ul></div><p class=entry-meta>By <a href=https://photographylife.com/author/spencer class=entry-author-link itemprop=url rel=author><span class=entry-author-name itemprop=name>Spencer Cox</span></a> <span class=entry-comments-link><a href=https://photographylife.com/reviews/arca-swiss-quick-link-set#comments>11 Comments</a></span><br>Last Updated On <time class=entry-time itemprop=dateModified datetime=2021-10-06>October 6, 2021</time></p></header><div class=entry-content><?xml encoding="UTF-8"><p>Arca Swiss&rsquo;s &ldquo;Quick Link Set&rdquo; is a duo of lightweight plates that go between your tripod and your tripod head, letting you attach and detach the head quickly. I&rsquo;ve been using the Quick Link Set recently and wanted to cover my impressions in today&rsquo;s review.</p><div id=ez-toc-container class="counter-hierarchy counter-decimal ez-toc-light-blue"><div class=ez-toc-title-container><p class=ez-toc-title>Table of Contents</p></div><nav><ul class=ez-toc-list><li><a href=#what-is-the-quick-link-set title="What Is the Quick Link Set?">What Is the Quick Link Set?</a></li><li><a href=#who-is-the-quick-link-set-for title="Who Is the Quick Link Set for?">Who Is the Quick Link Set for?</a></li><li><a href=#construction title=Construction>Construction</a></li><li><a href=#stability title=Stability>Stability</a></li><li><a href=#alternatives title=Alternatives>Alternatives</a></li><li><a href=#conclusion-and-recommendations title="Conclusion and Recommendations">Conclusion and Recommendations</a></li></ul></nav></div><h2><span class=ez-toc-section id=what-is-the-quick-link-set>What Is the Quick Link Set?</span></h2><p>The <a href=https://photographylife.com/arca-swiss-quick-release-system rel=noopener target=_blank>Arca Swiss</a> Quick Link Set consists of two plates: a disk that attaches to the bottom of your tripod head, and a receiver base that attaches to the top of your tripod. They look like this:</p><p><img loading=lazy class="aligncenter size-medium wp-image-242864 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20960%20470'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Disk-and-Receiver-Base-960x470.jpg alt="Arca Swiss Quick Link Set Disk and Receiver Base" width=960 height=470 data-srcset="https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Disk-and-Receiver-Base-960x470.jpg 960w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Disk-and-Receiver-Base-300x147.jpg 300w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Disk-and-Receiver-Base-768x376.jpg 768w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Disk-and-Receiver-Base-650x318.jpg 650w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Disk-and-Receiver-Base.jpg 1082w" data-sizes="(max-width: 960px) 100vw, 960px"></p><p>Once you&rsquo;ve attached these two plates to your tripod and head, using them is a matter of rotating the base to the &ldquo;open&rdquo; position, placing the tripod head on top, and rotating the base to the &ldquo;closed&rdquo; position.</p><p><a href=https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Steps.jpg><img loading=lazy class="aligncenter size-medium wp-image-242865 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20960%20503'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Steps-960x503.jpg alt="Arca Swiss Quick Link Set Steps" width=960 height=503 data-srcset="https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Steps-960x503.jpg 960w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Steps-300x157.jpg 300w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Steps-768x403.jpg 768w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Steps-1536x806.jpg 1536w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Steps-650x341.jpg 650w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Steps.jpg 2048w" data-sizes="(max-width: 960px) 100vw, 960px"></a></p><p>The receiver base weighs 103 g (3.6 oz), and the disk weighs 36 g (1.3 oz). They are compatible with any tripod and head brand, not just those from Arca Swiss, although I personally bought it to use with my <a href=https://photographylife.com/reviews/arca-swiss-c1-cube rel=noopener target=_blank>Arca Swiss C1 Cube</a>. Each receiver base costs $116, and each disk costs $83, although both together sell for a slightly discounted $183.</p><h2><span class=ez-toc-section id=who-is-the-quick-link-set-for>Who Is the Quick Link Set for?</span></h2><p>Plenty of photographers always use just one tripod with one head, and they rarely need to separate the two. If that&rsquo;s your situation, there&rsquo;s no reason to get the Quick Link Set, especially considering the price. But there are a few situations where the Quick Link Set (or something similar from other manufactures) is worthwhile.</p><div id=fs_content_ad></div><p>The first is simply if you find yourself swapping tripod heads frequently. Maybe you&rsquo;re a dual stills/video shooter with one tripod but two heads: a standard ballhead for photos, and a pan-tilt head for videos. Unscrewing them each time can be a slow process and may cause you to miss a shot. With a Quick Link disk on each tripod head and a receiver base on the tripod, you can swap between the heads in a matter of seconds.</p><p>Another reason to use the Quick Link is if you want to pack your tripod head away easily for travel or hiking. Personally, when I go hiking, I find that a heavy tripod can drag my backpack in an uncomfortable way. Maybe the tripod hangs off the side of the backpack, twisting my spine in that direction, or maybe it hangs off the back, making the tripod feel twice as heavy. Either way, the heavier the tripod head, the bigger the problem &ndash; and I&rsquo;m currently shooting with a heavy geared tripod head that can be uncomfortable to carry. With the Quick Link Set, I&rsquo;ve been detaching the head and storing it inside my backpack in a better spot to carry. Other photographers shooting with big geared heads, pan-tilt heads, or larger ballheads like the RRS BH-55 may be in a similar boat.</p><p>Finally, you may want to use the Quick Link Set if your tripod head doesn&rsquo;t do well in the elements, such as dusty and sandy conditions. This is especially true of a lot of geared heads, which often have their gear mechanism exposed to the outside world. It&rsquo;s a pain to unscrew the tripod head each time you&rsquo;re done shooting, but I know of some geared head shooters who do exactly that in order to avoid damaging their expensive equipment.</p><figure id=attachment_223731 aria-describedby=caption-attachment-223731 style="width: 960px" class="wp-caption aligncenter"><a href=https://photographylife.com/wp-content/uploads/2020/06/Dusty-Evening-in-Mesquite-Sand-Dunes-Death-Valley.jpg><img loading=lazy class="size-medium wp-image-223731 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20960%20641'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2020/06/Dusty-Evening-in-Mesquite-Sand-Dunes-Death-Valley-960x641.jpg alt="Dusty Evening in Mesquite Sand Dunes Death Valley" width=960 height=641 data-srcset="https://photographylife.com/wp-content/uploads/2020/06/Dusty-Evening-in-Mesquite-Sand-Dunes-Death-Valley-960x641.jpg 960w, https://photographylife.com/wp-content/uploads/2020/06/Dusty-Evening-in-Mesquite-Sand-Dunes-Death-Valley-300x200.jpg 300w, https://photographylife.com/wp-content/uploads/2020/06/Dusty-Evening-in-Mesquite-Sand-Dunes-Death-Valley-768x513.jpg 768w, https://photographylife.com/wp-content/uploads/2020/06/Dusty-Evening-in-Mesquite-Sand-Dunes-Death-Valley-1536x1025.jpg 1536w, https://photographylife.com/wp-content/uploads/2020/06/Dusty-Evening-in-Mesquite-Sand-Dunes-Death-Valley-650x434.jpg 650w, https://photographylife.com/wp-content/uploads/2020/06/Dusty-Evening-in-Mesquite-Sand-Dunes-Death-Valley-150x100.jpg 150w, https://photographylife.com/wp-content/uploads/2020/06/Dusty-Evening-in-Mesquite-Sand-Dunes-Death-Valley.jpg 2048w" data-sizes="(max-width: 960px) 100vw, 960px"></a><figcaption id=caption-attachment-223731 class=wp-caption-text>NIKON D800E + 70-200mm f/4 @ 175mm, ISO 100, 1/100, f/8.0</figcaption></figure><h2><span class=ez-toc-section id=construction>Construction</span></h2><p>The Quick Link Set has excellent build quality. The open/close mechanism is smooth and intuitive after using it just a few times. Also, the secondary hex-key screw (pictured below) means that the plates won&rsquo;t go anywhere once they&rsquo;re attached &ndash; a nice benefit over some tripod heads that can loosen or unscrew themselves if they&rsquo;re not locked tight.</p><p><a href=https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Hex-Key.jpg><img loading=lazy class="aligncenter size-medium wp-image-242868 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20960%20640'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Hex-Key-960x640.jpg alt="Arca Swiss Quick Link Set Hex Key" width=960 height=640 data-srcset="https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Hex-Key-960x640.jpg 960w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Hex-Key-300x200.jpg 300w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Hex-Key-768x512.jpg 768w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Hex-Key-1536x1025.jpg 1536w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Hex-Key-650x434.jpg 650w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Hex-Key-150x100.jpg 150w, https://photographylife.com/wp-content/uploads/2021/10/Arca-Swiss-Quick-Link-Set-Hex-Key.jpg 2048w" data-sizes="(max-width: 960px) 100vw, 960px"></a></p><p>Another important factor to consider is weight. While the Quick Link Set is reasonably light, it&rsquo;s still a bit heavier than you may want. The basic set (which includes one disk for your tripod head and one receiver base for your tripod) totals 139 g / 4.9 ounces. In other words, it&rsquo;s a bit lighter than two Nikon EN-EL15 batteries. Whether that&rsquo;s an issue or not depends on your own situation. If you&rsquo;re going on a difficult backpacking trip and rationing ounces, I&rsquo;d recommend against taking the Quick Link Set along. Otherwise, it&rsquo;s probably not an issue.</p><h2><span class=ez-toc-section id=stability>Stability</span></h2><p>A concern with tripod attachments like this, at least in theory, is stability. Rather than one pivot point between the tripod and the head, there are now three: between the tripod/base, base/disk, and disk/tripod head.</p><div id=fs_content_ad></div><p>To test the Quick Link Set&rsquo;s stability, I set up the largest and most unwieldy camera I have access to, an 11&times;14 camera that measures roughly&nbsp;one meter (three feet) long when extended and weighs about 9 kg (20 pounds) all told. As you can imagine, a camera like that is prone to wobble even on a stable tripod and head, and it&rsquo;s very sensitive to instability.&nbsp;I put a laser pointer on top of the camera, pressed down hard on the back standard, and let go. I then timed how long the laser pointer&rsquo;s wobble lasted on a wall, repeating the test for a total of 10 measurements without the Quick Link and then 10 tests with it.</p><p>Going without the plates, the wobble lasted for an average of 4.87 seconds. Going with the plates, the wobble actually averaged a hair shorter at&nbsp;4.81 seconds. However, these values are so similar that they&rsquo;re within my setup&rsquo;s margin of error. Overall, to the extent that I&rsquo;m able to test it, I found no meaningful loss of stability when using the Quick Link Set compared to going without it. Considering that my camera setup for this test was sensitive to very small differences in stability, photographers with a standard DSLR or mirrorless camera should find it even less of a concern.</p><p>The caveat is that you need to tighten down the Quick Link Set all the way, including using the secondary hex-key screws. If you attach either plate loosely &ndash; or you don&rsquo;t slide the receiver base to &ldquo;closed&rdquo; with sufficient force &ndash; you&rsquo;re at risk of adding some wobble.</p><h2><span class=ez-toc-section id=alternatives>Alternatives</span></h2><p>I have not tested any alternatives to the Arca Swiss version of the Quick Link Set, but I&rsquo;ll briefly cover the ones that exist on the market today.&nbsp;First, Leofoto sells a similar-looking knockoff version called the QS-70 that is about half the price of the Arca Swiss set, plus smaller variations called the QS-60, QS-50, and QS-45. At the time of publishing this review, they&rsquo;re only sold as a special order <a href=https://www.bhphotovideo.com/c/product/1638148-REG/leofoto_qs_70_70mm_quick_link.html/BI/5562/KBID/6400 target=_blank rel="noopener noreferrer nofollow sponsored">at B&amp;H</a> but are in stock <a href="https://www.amazon.com/Leofoto-QS-70-Tripod-Release-Mounting/dp/B08XWQBFHG?tag=photolife0c-20" target=_blank rel="noopener noreferrer nofollow sponsored">at Amazon</a>. Since I haven&rsquo;t tested them, I make no claim about their quality relative to Arca Swiss. I have used a couple Leofoto products in the past without issue, but there&rsquo;s also no denying that they &ldquo;take strong inspiration&rdquo; from Arca Swiss (to put it nicely) on some products, including this one.</p><p><img loading=lazy class="aligncenter size-full wp-image-242863 lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20648%20414'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2021/10/Leofoto-QS-70-Tripod-Head-Swap-Plate-and-Base.jpg alt="Leofoto QS-70 Tripod Head Swap Plate and Base" width=648 height=414 data-srcset="https://photographylife.com/wp-content/uploads/2021/10/Leofoto-QS-70-Tripod-Head-Swap-Plate-and-Base.jpg 648w, https://photographylife.com/wp-content/uploads/2021/10/Leofoto-QS-70-Tripod-Head-Swap-Plate-and-Base-300x192.jpg 300w" data-sizes="(max-width: 648px) 100vw, 648px"></p><p>The other option is a bit different. Rather than a circular plate and clamp, you could just attach a standard tripod plate to the bottom of your tripod head, then a standard (or panning) clamp to the top of your tripod. It looks like this:</p><figure id=attachment_242862 aria-describedby=caption-attachment-242862 style="width: 960px" class="wp-caption aligncenter"><img loading=lazy class="wp-image-242862 size-medium lazy" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20960%20762'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2021/10/Smallrig-Tripod-Head-Switch-960x762.jpg alt="Smallrig Tripod Head Switch" width=960 height=762 data-srcset="https://photographylife.com/wp-content/uploads/2021/10/Smallrig-Tripod-Head-Switch-960x762.jpg 960w, https://photographylife.com/wp-content/uploads/2021/10/Smallrig-Tripod-Head-Switch-300x238.jpg 300w, https://photographylife.com/wp-content/uploads/2021/10/Smallrig-Tripod-Head-Switch-768x609.jpg 768w, https://photographylife.com/wp-content/uploads/2021/10/Smallrig-Tripod-Head-Switch-650x516.jpg 650w, https://photographylife.com/wp-content/uploads/2021/10/Smallrig-Tripod-Head-Switch.jpg 1200w" data-sizes="(max-width: 960px) 100vw, 960px"><figcaption id=caption-attachment-242862 class=wp-caption-text>Another way to swap tripod heads quickly is to put a clamp on top of the tripod (pictured) and a plate on the bottom of each head (not pictured)</figcaption></figure><p>Again, I haven&rsquo;t tested this for stability and am just letting you know what else exists. My initial reaction is that the setup above doesn&rsquo;t look as stable as the circular Arca Swiss or Leofoto products whose clamps hug the entire disk. But if you already have the necessary supplies to put together the setup above (i.e. an extra tripod plate and clamp), or you&rsquo;re on a budget and want <a href=https://www.bhphotovideo.com/c/product/1510752-REG/smallrig_kdbc2406_tripod_head_quick_switch.html/BI/5562/KBID/6400 target=_blank rel="noopener noreferrer nofollow sponsored">SmallRig&rsquo;s inexpensive version</a>, it may be the way to go.</p><h2><span class=ez-toc-section id=conclusion-and-recommendations>Conclusion and Recommendations</span></h2><p>Is the Quick Link Set a worthwhile accessory, or is it just an expensive product in search of a need? It all depends on how you tend to use your tripod. If you&rsquo;d find it useful to swap out your tripod head quickly, it&rsquo;s worth getting (or at least worth looking at the knockoff Leofoto if the Arca Swiss is over your budget). But if you&rsquo;re shaking your head at that, don&rsquo;t buy it.</p><p>I ended up purchasing a set and have found it helpful for my landscape photography. When I&rsquo;m hiking, I can remove and stow my heavy geared head in a comfortable spot inside my backpack rather than hanging it off the side of the bag. It also lets me avoid exposing the geared head to the elements &ndash; not the head&rsquo;s strong suit, especially in sandy conditions. But my situation is pretty specific and matches the Quick Link Set&rsquo;s strengths very well.</p><p>Other than that, it&rsquo;s no surprise that this type of tripod accessory isn&rsquo;t a common sight. The Quick Link Set is fairly expensive and adds weight without solving any commonly occurring problems in photography. Sure, it&rsquo;s very stable and well-built, but is it necessary? As I see it, the Quick Link Set is one of those &ldquo;if you need it, you know&rdquo; sorts of products. If it fits your situation, there&rsquo;s little to complain about aside from price. But for many photographers, it just doesn&rsquo;t offer features that are especially relevant.</p><ul> <li>You can purchase the Quick Link Set for $212 from <a href=https://www.bhphotovideo.com/c/product/1513554-REG/arca_swiss_802320_quicklink_set.html/BI/5562/KBID/6400 target=_blank rel="noopener noreferrer nofollow sponsored">B&amp;H</a>, &euro;175 from&nbsp;<a href=https://www.arca-shop.de/en/tripod-heads/upgradeconversion/39/quick-link-set target=_blank rel=noopener>Arca Swiss</a>, or $183 from Arca Swiss&rsquo;s USA representative <a href=https://www.rodklukas.com target=_blank rel=noopener>Rod Klukas</a></li> <li>You can get extra disks (for multiple tripod heads) for $115 from <a href=https://www.bhphotovideo.com/c/product/1513555-REG/arca_swiss_802320_1_quicklink_disk_for_quicklink.html/BI/5562/KBID/6400 target=_blank rel="noopener noreferrer nofollow sponsored">B&amp;H</a>, &euro;81 from&nbsp;<a href=https://www.arca-shop.de/en/tripod-heads/upgradeconversion/258/quick-link-disk-only target=_blank rel=noopener>Arca Swiss</a>, and $83 from <a href=https://www.rodklukas.com target=_blank rel=noopener>Rod Klukas</a></li> <li>You can get extra receiver bases (for multiple tripods) for $116 from <a href=https://www.bhphotovideo.com/c/product/1611836-REG/arca_swiss_802320_2_quick_link_base_only.html/BI/5562/KBID/6400 target=_blank rel="noopener noreferrer nofollow sponsored">B&amp;H</a>, &euro;113 from&nbsp;<a href=https://www.arca-shop.de/en/tripod-heads/upgradeconversion/1890/quick-link-base-only target=_blank rel=noopener>Arca Swiss</a>, and $116 from&nbsp;<a href=https://www.rodklukas.com target=_blank rel=noopener>Rod Klukas</a></li></ul><div id=review class="review-wrapper "><h5 class="review-title">Arca Swiss Quick Link Set</h5><ul class=review-list><li><span>Features</span><div class=review-star><div class=review-result-wrapper><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><div class=review-result style=width:60%;><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i></div></div></div></li><li><span>Build Quality</span><div class=review-star><div class=review-result-wrapper><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><div class=review-result style=width:100%;><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i></div></div></div></li><li><span>Size and Weight</span><div class=review-star><div class=review-result-wrapper><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><div class=review-result style=width:90%;><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i></div></div></div></li><li><span>Stability</span><div class=review-star><div class=review-result-wrapper><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><div class=review-result style=width:100%;><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i></div></div></div></li><li><span>Value</span><div class=review-star><div class=review-result-wrapper><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><div class=review-result style=width:70%;><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i></div></div></div></li></ul><div class=review-desc><p class=review-summary-title><strong>Photography Life Overall Rating</strong></p></div><div class=review-total-wrapper> <span class=review-total-box>4.2</span><div class=review-total-star><div class=review-result-wrapper><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><div class=review-result style=width:84%;><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i><i class=mts-icon-star></i></div></div></div></div></div></p></div><footer class=entry-footer><div align=center id=PhotographyLife_300x250_728x90_320x50_EndOfPosts> <script data-cfasync=false>freestar.config.enabled_slots.push({placementName:"PhotographyLife_300x250_728x90_320x50_EndOfPosts",slotId:"PhotographyLife_300x250_728x90_320x50_EndOfPosts"});</script> </div><section id=yikes-mailchimp-container-2 class="yikes-mailchimp-container yikes-mailchimp-container-2 "><h3 class="yikes-mailchimp-form-title yikes-mailchimp-form-title-2">Subscribe to Our Newsletter</h3><section class="yikes-mailchimp-form-description yikes-mailchimp-form-description-2">If you liked this article, please subscribe below to our weekly email to get more great content like this!</section><form id=subscribe-to-our-newsletter-2 class="yikes-easy-mc-form yikes-easy-mc-form-2  " method=POST data-attr-form-id=2><label for=yikes-easy-mc-form-2-EMAIL  class="EMAIL-label yikes-mailchimp-field-required "> <span class=EMAIL-label> Email Address	</span> <input id=yikes-easy-mc-form-2-EMAIL  name=EMAIL  placeholder  class="yikes-easy-mc-email "  required=required type=email  value> </label> <label for=yikes-easy-mc-form-2-FNAME  class="FNAME-label "> <span class=FNAME-label> First Name	</span> <input id=yikes-easy-mc-form-2-FNAME  name=FNAME  placeholder  class="yikes-easy-mc-text "   type=text  value> </label> <label class=yikes-mailchimp-eu-compliance-label><input type=checkbox required=required name=eu-laws value=1><div class=yikes-mailchimp-eu-compliance-text><p>By checking this box I consent to the use of my information, as detailed in the <a rel=nofollow href=https://photographylife.com/privacy-policy rel=noopener target=_blank>Privacy Policy</a>.</p></div></label> <input type=hidden name=yikes-mailchimp-honeypot id=yikes-mailchimp-honeypot-2 value> <input type=hidden name=yikes-mailchimp-associated-list-id id=yikes-mailchimp-associated-list-id-2 value=74d1711c3d> <input type=hidden name=yikes-mailchimp-submitted-form id=yikes-mailchimp-submitted-form-2 value=2> <button type=submit class="yikes-easy-mc-submit-button yikes-easy-mc-submit-button-2 btn btn-primary "> <span class=yikes-mailchimp-submit-button-span-text>Subscribe</span></button> <input type=hidden id=yikes_easy_mc_new_subscriber_2 name=yikes_easy_mc_new_subscriber value=7fa448fcc5> <input type=hidden name=_wp_http_referer value=/reviews/arca-swiss-quick-link-set></form></section><div id=connatix-video-incontent-desktop></div><div class="rp4wp-related-posts rp4wp-related-reviews"><h3>Related Articles</h3><ul class=rp4wp-posts-list> <li class="rp4wp-col rp4wp-col-first"><div class="rp4wp_component rp4wp_component_image rp4wp_component_2"><a href=https://photographylife.com/arca-swiss-quick-release-system><img width=150 height=150 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2014/01/Nikon-D850-RRS-Arca-Swiss-L-Bracket-150x150.jpg class="attachment-mini-thumb size-mini-thumb wp-post-image lazy" alt="Nikon D850 RRS Arca Swiss L Bracket" loading=lazy></a></div><div class="rp4wp_component rp4wp_component_title rp4wp_component_3"><a href=https://photographylife.com/arca-swiss-quick-release-system>Arca-Swiss Quick Release System Explained</a></div></li><li class=rp4wp-col><div class="rp4wp_component rp4wp_component_image rp4wp_component_2"><a href=https://photographylife.com/reviews/arca-swiss-c1-cube><img width=150 height=150 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2014/03/Arca-Swiss-C1-Cube-150x150.jpg class="attachment-mini-thumb size-mini-thumb wp-post-image lazy" alt="Arca-Swiss C1 Cube" loading=lazy></a></div><div class="rp4wp_component rp4wp_component_title rp4wp_component_3"><a href=https://photographylife.com/reviews/arca-swiss-c1-cube>Arca-Swiss C1 Cube Review</a></div></li><li class="rp4wp-col rp4wp-col-last"><div class="rp4wp_component rp4wp_component_image rp4wp_component_2"><a href=https://photographylife.com/reviews/hejnar-photo-accessory><img width=150 height=150 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2014/01/Manfrotto-405-Arca-Swiss-Hejnar-Photo-150x150.jpg class="attachment-mini-thumb size-mini-thumb wp-post-image lazy" alt="Manfrotto 405 Arca Swiss Hejnar Photo" loading=lazy></a></div><div class="rp4wp_component rp4wp_component_title rp4wp_component_3"><a href=https://photographylife.com/reviews/hejnar-photo-accessory>Hejnar Photo Accessory Review</a></div></li><li class="rp4wp-col rp4wp-col-first"><div class="rp4wp_component rp4wp_component_image rp4wp_component_2"><a href=https://photographylife.com/reviews/really-right-stuff-bh-55-ballhead><img width=150 height=150 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2015/04/Really-Right-Stuff-BH-55-Pro-Ballhead-150x150.jpg class="attachment-mini-thumb size-mini-thumb wp-post-image lazy" alt="Really Right Stuff BH-55 Pro Ballhead" loading=lazy></a></div><div class="rp4wp_component rp4wp_component_title rp4wp_component_3"><a href=https://photographylife.com/reviews/really-right-stuff-bh-55-ballhead>Really Right Stuff BH-55 Ballhead Review</a></div></li><li class=rp4wp-col><div class="rp4wp_component rp4wp_component_image rp4wp_component_2"><a href=https://photographylife.com/reviews/vello-econo-extension-tube-set-for-nikon-1><img width=150 height=150 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2014/10/Vello-extension-tubes-image-1-150x150.jpg class="attachment-mini-thumb size-mini-thumb wp-post-image lazy" alt="Vello extension tubes image 1" loading=lazy></a></div><div class="rp4wp_component rp4wp_component_title rp4wp_component_3"><a href=https://photographylife.com/reviews/vello-econo-extension-tube-set-for-nikon-1>Vello Econo Extension Tube Set for Nikon 1 Mount Review</a></div></li><li class="rp4wp-col rp4wp-col-last"><div class="rp4wp_component rp4wp_component_image rp4wp_component_2"><a href=https://photographylife.com/reviews/linhof-3d-micro><img width=150 height=150 src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20150%20150'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2014/03/Linhof-3D-Micro-150x150.jpg class="attachment-mini-thumb size-mini-thumb wp-post-image lazy" alt="Linhof 3D Micro" loading=lazy></a></div><div class="rp4wp_component rp4wp_component_title rp4wp_component_3"><a href=https://photographylife.com/reviews/linhof-3d-micro>Linhof 3D Micro Review</a></div></li></ul></div><div style="margin-top: 20px; font-size: 12px; text-transform: uppercase;"><a href=/disclosures target=_blank>Disclosures</a>, <a href=/terms-and-conditions target=_blank>Terms and Conditions</a> and <a href=/support-us target=_blank>Support Options</a></div><div class="entry-footer entry-meta"> <span class=entry-categories>Filed Under: <a href=https://photographylife.com/category/accessories rel="category tag">Camera Gear Accessories</a></span> <span class=entry-tags>Tagged With: <a href=https://photographylife.com/tag/camera-accessories rel=tag>Camera Accessories</a>, <a href=https://photographylife.com/tag/gear-reviews rel=tag>Gear Reviews</a>, <a href=https://photographylife.com/tag/product-reviews rel=tag>Product Reviews</a>, <a href=https://photographylife.com/tag/tripod-heads rel=tag>Tripod Heads</a>, <a href=https://photographylife.com/tag/tripods rel=tag>Tripods</a></span></div></footer></article><section class=author-box><img alt src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2070%2070'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/cc647c2d677a7bc7d17a581386ace3b5?s=70&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/cc647c2d677a7bc7d17a581386ace3b5?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo lazy' height=70 width=70 loading=lazy><h4 class="author-box-title">About <span itemprop=name>Spencer Cox</span></h4><div class=author-box-content itemprop=description><p>I'm Spencer Cox, a macro and landscape photographer based in Denver. My photos have been displayed in galleries worldwide, including the Smithsonian Museum of Natural History and exhibitions in London, Malta, Siena, and Beijing. These days I'm active on <a href=https://www.instagram.com/spencercoxphoto/ rel="nofollow noopener">Instagram</a> and <a href=https://www.youtube.com/c/spencercoxphoto rel="nofollow noopener">YouTube</a>.</p></div></section><div class=wpdiscuz_top_clearing></div><div id=comments class=comments-area><div id=respond style='width: 0;height: 0;clear: both;margin: 0;padding: 0;'></div><div id=wpdcom class="wpdiscuz_unauth wpd-default wpd-layout-2 wpd-comments-open"><div class=wc_social_plugin_wrapper></div><div class=wpd-form-wrap><div class=wpd-form-head><div class=wpd-auth><div class=wpd-login></div></div></div><div class="wpd-form wpd-form-wrapper wpd-main-form-wrapper" id=wpd-main-form-wrapper-0_0><form class="wpd_comm_form wpd_main_comm_form" method=post enctype=multipart/form-data><div class=wpd-field-comment><div class="wpdiscuz-item wc-field-textarea"><div class="wpdiscuz-textarea-wrap wpd-txt"><div class=wpd-avatar> <img alt=guest src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2056%2056'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/?s=56&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/?s=112&#038;d=mm&#038;r=g 2x' class='avatar avatar-56 photo avatar-default lazy' height=56 width=56 loading=lazy></div><div class=wpd-textarea-wrap><div id=wpd-editor-char-counter-0_0 class=wpd-editor-char-counter></div> <label style="display: none;" for=wc-textarea-0_0>Label</label><textarea id=wc-textarea-0_0   placeholder="Join the discussion" aria-label="Join the discussion" required name=wc_comment class="wc_comment wpd-field"></textarea></div><div class=wpd-editor-buttons-right></div></div></div></div><div class=wpd-form-foot style=display:none;><div class=wpdiscuz-textarea-foot><div class=wpdiscuz-button-actions></div></div><div class=wpd-form-row><div class=wpd-form-col-left><div class="wpdiscuz-item wc_name-wrapper wpd-has-icon"><div class=wpd-field-icon><i class="fas fa-user"></i></div> <input id=wc_name-0_0 value required=required aria-required=true class="wc_name wpd-field" type=text name=wc_name placeholder=Name* maxlength=50 pattern=.{3,50} title> <label for=wc_name-0_0 class=wpdlb>Name*</label></div><div class="wpdiscuz-item wc_email-wrapper wpd-has-icon"><div class=wpd-field-icon><i class="fas fa-at"></i></div> <input id=wc_email-0_0 value required=required aria-required=true class="wc_email wpd-field" type=email name=wc_email placeholder=Email*> <label for=wc_email-0_0 class=wpdlb>Email*</label></div></div><div class=wpd-form-col-right><div class=wc-field-submit> <input id=wpd-field-submit-0_0 class="wc_comm_submit wpd_not_clicked wpd-prim-button" type=submit name=submit value="Post Comment"></div></div><div class=clearfix></div></div></div> <input type=hidden class=wpdiscuz_unique_id value=0_0 name=wpdiscuz_unique_id></form></div><div id=wpdiscuz_hidden_secondary_form style="display: none;"><div class="wpd-form wpd-form-wrapper wpd-secondary-form-wrapper" id=wpd-secondary-form-wrapper-wpdiscuzuniqueid style='display: none;'><div class=wpd-secondary-forms-social-content></div><div class=clearfix></div><form class="wpd_comm_form wpd-secondary-form-wrapper" method=post enctype=multipart/form-data><div class=wpd-field-comment><div class="wpdiscuz-item wc-field-textarea"><div class="wpdiscuz-textarea-wrap wpd-txt"><div class=wpd-avatar> <img alt=guest src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2056%2056'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/?s=56&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/?s=112&#038;d=mm&#038;r=g 2x' class='avatar avatar-56 photo avatar-default lazy' height=56 width=56 loading=lazy></div><div class=wpd-textarea-wrap><div id=wpd-editor-char-counter-wpdiscuzuniqueid class=wpd-editor-char-counter></div> <label style="display: none;" for=wc-textarea-wpdiscuzuniqueid>Label</label><textarea id=wc-textarea-wpdiscuzuniqueid   placeholder="Join the discussion" aria-label="Join the discussion" required name=wc_comment class="wc_comment wpd-field"></textarea></div><div class=wpd-editor-buttons-right></div></div></div></div><div class=wpd-form-foot style=display:none;><div class=wpdiscuz-textarea-foot><div class=wpdiscuz-button-actions></div></div><div class=wpd-form-row><div class=wpd-form-col-left><div class="wpdiscuz-item wc_name-wrapper wpd-has-icon"><div class=wpd-field-icon><i class="fas fa-user"></i></div> <input id=wc_name-wpdiscuzuniqueid value required=required aria-required=true class="wc_name wpd-field" type=text name=wc_name placeholder=Name* maxlength=50 pattern=.{3,50} title> <label for=wc_name-wpdiscuzuniqueid class=wpdlb>Name*</label></div><div class="wpdiscuz-item wc_email-wrapper wpd-has-icon"><div class=wpd-field-icon><i class="fas fa-at"></i></div> <input id=wc_email-wpdiscuzuniqueid value required=required aria-required=true class="wc_email wpd-field" type=email name=wc_email placeholder=Email*> <label for=wc_email-wpdiscuzuniqueid class=wpdlb>Email*</label></div></div><div class=wpd-form-col-right><div class=wc-field-submit> <input id=wpd-field-submit-wpdiscuzuniqueid class="wc_comm_submit wpd_not_clicked wpd-prim-button" type=submit name=submit value="Post Comment"></div></div><div class=clearfix></div></div></div> <input type=hidden class=wpdiscuz_unique_id value=wpdiscuzuniqueid name=wpdiscuz_unique_id></form></div></div></div><div id=wpd-threads class=wpd-thread-wrapper><div class=wpd-thread-head><div class="wpd-thread-info " data-comments-count=11> <span class=wpdtc title=11>11</span> Comments</div><div class=wpd-space></div><div class=wpd-thread-filter><div class="wpd-filter wpdf-sorting"> <span class="wpdiscuz-sort-button wpdiscuz-date-sort-desc wpdiscuz-sort-button-active" data-sorting=newest>Newest</span> <i class="fas fa-sort-down"></i><div class=wpdiscuz-sort-buttons> <span class="wpdiscuz-sort-button wpdiscuz-date-sort-asc" data-sorting=oldest>Oldest</span> <span class="wpdiscuz-sort-button wpdiscuz-vote-sort-up" data-sorting=by_vote>Most Voted</span></div></div></div></div><div class=wpd-comment-info-bar><div class=wpd-current-view><i class="fas fa-quote-left"></i> Inline Feedbacks</div><div class=wpd-filter-view-all>View all comments</div></div><div class=wpd-thread-list><div id=wpd-comm-302387_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-guest"><div id=comment-302387 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt=Marcin src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/018fe827aeebe69dcdd31010fb6d22a5?s=64&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/018fe827aeebe69dcdd31010fb6d22a5?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo lazy' height=64 width=64 loading=lazy></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> Marcin</div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="October 7, 2021 3:45 am"> <i class='far fa-clock' aria-hidden=true></i> October 7, 2021 3:45 am</div></div></div></div><div class=wpd-comment-text><p>You should update the Alternatives section with the newly announced Move system by Manfrotto: <a href=https://petapixel.com/2021/10/05/the-manfrotto-move-is-a-modular-support-system-for-the-hybrid-shooter/ rel=nofollow target=_blank title="URL: https://petapixel.com/2021/10/05/the-manfrotto-move-is-a-modular-support-system-for-the-hybrid-shooter/">petapixel.com/2021/&#8230;d-shooter/</a></p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-reply-button> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill=none /></svg> <span>Reply</span></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-302387_0></div></div><div id=wpd-comm-302380_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-guest"><div id=comment-302380 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt='Rodney Klukas' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/8c5c00fa32590a625af0d02c3fa88b4d?s=64&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/8c5c00fa32590a625af0d02c3fa88b4d?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo lazy' height=64 width=64 loading=lazy></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> Rodney Klukas</div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="October 6, 2021 10:32 am"> <i class='far fa-clock' aria-hidden=true></i> October 6, 2021 10:32 am</div></div></div></div><div class=wpd-comment-text><p>Spencer, Thank you for a good and fair review. The Quick Links are actually $183.00 for the kit, including 1 receiver and one head plate. A separate head plate is $83.00 and a separate receiver is $116.00. This is designed to keep the heads base centered on the tripod with its design. A standard QR in most cases is a longitudinal plate with a channel and may place the head off center. This can cause movements, especially panoramic shooting to be less precise, causing issues at times with stitching. Also an expensive head should be protected, especially when traveling, given the airlines propensity for tossing things. So removal to the back pack or camera case, can be very helpful in<span id=wpdiscuz-readmore-302380_0><span class=wpdiscuz-hellip>&hellip;&nbsp;</span><span class=wpdiscuz-readmore title='Read more &raquo;'>Read more &raquo;</span></span></p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-reply-button> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill=none /></svg> <span>Reply</span></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-302380_0></div><div id=wpd-comm-302381_302380 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-302381 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt='Spencer Cox' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/cc647c2d677a7bc7d17a581386ace3b5?s=64&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/cc647c2d677a7bc7d17a581386ace3b5?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo lazy' height=64 width=64 loading=lazy></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> Spencer Cox</div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-302380> Rodney Klukas </a></div><div class=wpd-comment-date title="October 6, 2021 12:52 pm"> <i class='far fa-clock' aria-hidden=true></i> October 6, 2021 12:52 pm</div></div></div></div><div class=wpd-comment-text><p>Thanks, Rod! I updated the article with the right prices. And thanks again for the help when I was buying this gear, the Cube has been working great so far with the 11&#215;14.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-reply-button> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill=none /></svg> <span>Reply</span></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-302381_302380></div></div></div><div id=wpd-comm-302379_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-guest"><div id=comment-302379 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt=KomradeKiev src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/25fb06fe40734b04908923c9613949c4?s=64&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/25fb06fe40734b04908923c9613949c4?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo lazy' height=64 width=64 loading=lazy></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> KomradeKiev</div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="October 6, 2021 10:06 am"> <i class='far fa-clock' aria-hidden=true></i> October 6, 2021 10:06 am</div></div></div></div><div class=wpd-comment-text><p>The QuickLinks system is awesome. Like you, I don&#8217;t want to hike with a heavy head mounted. My full-sized tripod is heavy enough strapped to the side of my pack. I didn&#8217;t want to deal with a screw-knob, so threading a traditional quick release clamp to the tripod and an appropriate plate to the underside of the head was not appealing. Kirk&#8217;s system is too heavy and tall. Seastars are too tall. ASQ is the lowest profile and lightest of the systems that I know of, but fairly spendy. But once I got a set, and appreciated the elegance, simplicity, and build quality, I forgot what I paid for them. :)</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-reply-button> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill=none /></svg> <span>Reply</span></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-302379_0></div><div id=wpd-comm-302382_302379 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-302382 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt='Spencer Cox' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/cc647c2d677a7bc7d17a581386ace3b5?s=64&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/cc647c2d677a7bc7d17a581386ace3b5?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo lazy' height=64 width=64 loading=lazy></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> Spencer Cox</div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-302379> KomradeKiev </a></div><div class=wpd-comment-date title="October 6, 2021 12:55 pm"> <i class='far fa-clock' aria-hidden=true></i> October 6, 2021 12:55 pm</div></div></div></div><div class=wpd-comment-text><p>Sounds like for your purposes, it’s a great fit! The price on Arca Swiss or similar quality gear is always high, but this stuff does last for ages.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-reply-button> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill=none /></svg> <span>Reply</span></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-302382_302379></div></div></div><div id=wpd-comm-302378_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-guest"><div id=comment-302378 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt=Andrew src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/944f8d1d1ddd743ee209cfc8bc51256b?s=64&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/944f8d1d1ddd743ee209cfc8bc51256b?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo lazy' height=64 width=64 loading=lazy></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> Andrew</div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="October 6, 2021 8:48 am"> <i class='far fa-clock' aria-hidden=true></i> October 6, 2021 8:48 am</div></div></div></div><div class=wpd-comment-text><p>I bought a couple of iFootage Seastars. As with most iFootage products, they are excellent quality. However, as with all of these, you need usually need 2 or 3 of them to make it worthwhile.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-reply-button> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill=none /></svg> <span>Reply</span></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-302378_0></div><div id=wpd-comm-302383_302378 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-302383 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt='Spencer Cox' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/cc647c2d677a7bc7d17a581386ace3b5?s=64&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/cc647c2d677a7bc7d17a581386ace3b5?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo lazy' height=64 width=64 loading=lazy></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> Spencer Cox</div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-302378> Andrew </a></div><div class=wpd-comment-date title="October 6, 2021 12:55 pm"> <i class='far fa-clock' aria-hidden=true></i> October 6, 2021 12:55 pm</div></div></div></div><div class=wpd-comment-text><p>Nice, I hadn’t seen those, but they seem to work in a very similar way.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-reply-button> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill=none /></svg> <span>Reply</span></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-302383_302378></div></div></div><div id=wpd-comm-302377_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-guest"><div id=comment-302377 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt='JOHN J MOTZI' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/9eb2ea74c2106f081de160a7aa78dfa5?s=64&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/9eb2ea74c2106f081de160a7aa78dfa5?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo lazy' height=64 width=64 loading=lazy></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> JOHN J MOTZI</div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="October 6, 2021 6:19 am"> <i class='far fa-clock' aria-hidden=true></i> October 6, 2021 6:19 am</div></div></div></div><div class=wpd-comment-text><p>Hi Spencer, thanks for this!  It looks like a nice product.</p><p>The only other solution I know of takes some work.  I have drilled and tapped my tripod top plates so I could fasten a RRS TA-LBC ROUND LEVER RELEASE CLAMP to the plate.  Then on the bottom of each head, one attaches a large dovetail plate such as the RRS TH-DVTL-55 in the usual way.  It works very well &#8211; I can quickly exchange any head onto any tripod.  But one must be handy for the plate modification and RRS parts are not always in stock.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-reply-button> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill=none /></svg> <span>Reply</span></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-302377_0></div><div id=wpd-comm-302384_302377 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-302384 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt='Spencer Cox' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/cc647c2d677a7bc7d17a581386ace3b5?s=64&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/cc647c2d677a7bc7d17a581386ace3b5?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo lazy' height=64 width=64 loading=lazy></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> Spencer Cox</div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-302377> JOHN J MOTZI </a></div><div class=wpd-comment-date title="October 6, 2021 12:56 pm"> <i class='far fa-clock' aria-hidden=true></i> October 6, 2021 12:56 pm</div></div></div></div><div class=wpd-comment-text><p>The DIY approaches usually have some nice benefits in price if you’re able to make them work! Sounds like you found a good solution.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-reply-button> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill=none /></svg> <span>Reply</span></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-302384_302377></div></div></div><div id=wpd-comm-302371_0 class='wpd-comment wpd_comment_level-1'><div class="wpd-comment-wrap wpd-blog-guest"><div id=comment-302371 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt=PedroS src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/d294c498ce55889302ba024d57c52d3e?s=64&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/d294c498ce55889302ba024d57c52d3e?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo lazy' height=64 width=64 loading=lazy></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> PedroS</div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-comment-date title="October 6, 2021 2:26 am"> <i class='far fa-clock' aria-hidden=true></i> October 6, 2021 2:26 am</div></div></div></div><div class=wpd-comment-text><p>Another nice and informative article.<br> I&#8217;m using, for a couple of years now, the last setup you refer, meaning a quick release Arca clamp and plates on my tripod heads.<br> My question is, why do you consider less stable? Majority of our tripod head lenses connections goes that way&#8230;<br> Thanks</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-reply-button> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill=none /></svg> <span>Reply</span></div><div class=wpd-space></div><div class="wpd-toggle wpd-hidden wpd_not_clicked" wpd-tooltip="Hide Replies"> <i class='fas fa-chevron-up'></i></div></div></div></div><div id=wpdiscuz_form_anchor-302371_0></div><div id=wpd-comm-302385_302371 class='wpd-comment wpd-reply wpd_comment_level-2'><div class="wpd-comment-wrap wpd-blog-user wpd-blog-post_author"><div id=comment-302385 class=wpd-comment-right><div class=wpd-comment-header><div class="wpd-avatar "> <img alt='Spencer Cox' src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%2064%2064'%3E%3C/svg%3E" data-src='https://secure.gravatar.com/avatar/cc647c2d677a7bc7d17a581386ace3b5?s=64&#038;d=mm&#038;r=g' data-srcset='https://secure.gravatar.com/avatar/cc647c2d677a7bc7d17a581386ace3b5?s=128&#038;d=mm&#038;r=g 2x' class='avatar avatar-64 photo lazy' height=64 width=64 loading=lazy></div><div class=wpd-user-info><div class=wpd-uinfo-top><div class="wpd-comment-author "> Spencer Cox</div><div class=wpd-comment-label wpd-tooltip=Author wpd-tooltip-position=top> <span>Author</span></div><div class=wpd-space></div></div><div class=wpd-uinfo-bottom><div class=wpd-reply-to> <i class='far fa-comments'></i> Reply to&nbsp; <a href=#comment-302371> PedroS </a></div><div class=wpd-comment-date title="October 6, 2021 1:00 pm"> <i class='far fa-clock' aria-hidden=true></i> October 6, 2021 1:00 pm</div></div></div></div><div class=wpd-comment-text><p>I think that for most uses, any differences would be very tough to tell. But with supertelephoto lenses or some other large camera setup, the small differences add up. If you aren’t noticing any instability with your clamp setup (maybe performing the same test I did in this article, but with your longest lens) there’s no reason for concern.</p></div><div class=wpd-comment-footer><div class=wpd-vote><div class="wpd-vote-up wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0V0z'/><path d='M1 21h4V9H1v12zm22-11c0-1.1-.9-2-2-2h-6.31l.95-4.57.03-.32c0-.41-.17-.79-.44-1.06L14.17 1 7.59 7.59C7.22 7.95 7 8.45 7 9v10c0 1.1.9 2 2 2h9c.83 0 1.54-.5 1.84-1.22l3.02-7.05c.09-.23.14-.47.14-.73v-2z'/></svg></div><div class=wpd-vote-result title=0>0</div><div class="wpd-vote-down wpd_not_clicked"> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path fill=none d='M0 0h24v24H0z'/><path d='M15 3H6c-.83 0-1.54.5-1.84 1.22l-3.02 7.05c-.09.23-.14.47-.14.73v2c0 1.1.9 2 2 2h6.31l-.95 4.57-.03.32c0 .41.17.79.44 1.06L9.83 23l6.59-6.59c.36-.36.58-.86.58-1.41V5c0-1.1-.9-2-2-2zm4 0v12h4V3h-4z'/></svg></div></div><div class=wpd-reply-button> <svg xmlns=https://www.w3.org/2000/svg viewBox='0 0 24 24'><path d='M10 9V5l-7 7 7 7v-4.1c5 0 8.5 1.6 11 5.1-1-5-4-10-11-11z'/><path d='M0 0h24v24H0z' fill=none /></svg> <span>Reply</span></div><div class=wpd-space></div></div></div></div><div id=wpdiscuz_form_anchor-302385_302371></div></div></div><div class=wpdiscuz-comment-pagination></div></div></div></div></div><div id=wpdiscuz-loading-bar class=wpdiscuz-loading-bar-unauth></div><div id=wpdiscuz-comment-message class=wpdiscuz-comment-message-unauth></div></main><aside class="sidebar sidebar-primary widget-area" role=complementary aria-label="Primary Sidebar"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id=text-4 class="widget widget_text"><div class=widget-wrap><h3 class="widgettitle widget-title">Learn</h3><div class=textwidget><ul> <li class=cat-item><a title="Beginner Photography" href=https://photographylife.com/learn-photography>Beginner Photography</a></li> <li class=cat-item><a title="Landscape Photography" href=https://photographylife.com/landscapes>Landscape Photography</a></li> <li class=cat-item><a title="Wildlife Photography" href=https://photographylife.com/wildlife-photography-tips>Wildlife Photography</a></li> <li class=cat-item><a title=Portraiture href=https://photographylife.com/portrait-photography>Portraiture</a></li> <li class=cat-item><a title=Post-Processing href=https://photographylife.com/post-processing-tips-for-beginners>Post-Processing</a></li> <li class=cat-item><a title="Advanced Tutorials" href=https://photographylife.com/advanced-photography-tutorials>Advanced Tutorials</a></li></ul></div></div></section><section id=pl_sidebar_top_widget-3 class="widget widget_text"><div class=widget-wrap><div align=center data-freestar-ad=__300x250 id=PhotographyLife_300x600_300x250_160x600_Sidebar_ATF> <script data-cfasync=false>freestar.config.enabled_slots.push({placementName:"PhotographyLife_300x600_300x250_160x600_Sidebar_ATF",slotId:"PhotographyLife_300x600_300x250_160x600_Sidebar_ATF"});</script> </div></div></section><section id=text-8 class="widget widget_text"><div class=widget-wrap><h3 class="widgettitle widget-title">Reviews</h3><div class=textwidget><ul> <li class=cat-item><a title="Camera Reviews" href=https://photographylife.com/camera-reviews>Camera Reviews</a></li> <li class=cat-item><a title="Lens Reviews" href=https://photographylife.com/lens-reviews>Lens Reviews</a></li> <li class=cat-item><a title="Other Gear Reviews" href=https://photographylife.com/other-gear-reviews>Other Gear Reviews</a></li> <li class=cat-item><a title="Best Cameras and Lenses" href=https://photographylife.com/best-cameras-and-lenses>Best Cameras and Lenses</a></li></ul></div></div></section><section id=pl_sidebar_middle_widget-2 class="widget widget_text"><div class=widget-wrap><div align=center data-freestar-ad=__300x250 id=Photographylife_rail_right> <script data-cfasync=false>freestar.config.enabled_slots.push({placementName:"Photographylife_rail_right",slotId:"Photographylife_rail_right"});</script> </div></div></section><section id=text-6 class="widget widget_text"><div class=widget-wrap><h3 class="widgettitle widget-title">Photography Tutorials</h3><div class=textwidget><div class=pl-tutorials><div class="pl-tutorials-basics pl-tutorials-bg"><a href=https://photographylife.com/photography-basics><span class=pl-tutorials-title>Photography Basics</span></a></div><div class="pl-tutorials-landscape pl-tutorials-bg"><a href=https://photographylife.com/landscapes/landscape-photography-guide><span class=pl-tutorials-title>Landscape Photography</span></a></div><div class="pl-tutorials-wildlife pl-tutorials-bg"><a href=https://photographylife.com/wildlife-photography-tutorial><span class=pl-tutorials-title>Wildlife Photography</span></a></div><div class="pl-tutorials-macro pl-tutorials-bg"><a href=https://photographylife.com/macro-photography-tutorial><span class=pl-tutorials-title>Macro Photography</span></a></div><div class="pl-tutorials-composition pl-tutorials-bg"><a href=https://photographylife.com/composition-guide><span class=pl-tutorials-title>Composition &#038; Creativity</span></a></div><div class="pl-tutorials-bw pl-tutorials-bg"><a href=https://photographylife.com/black-and-white-photography><span class=pl-tutorials-title>Black &#038; White Photography</span></a></div><div class="pl-tutorials-night pl-tutorials-bg"><a href=https://photographylife.com/landscapes/how-to-photograph-the-milky-way><span class=pl-tutorials-title>Night Sky Photography</span></a></div><div class="pl-tutorials-portrait pl-tutorials-bg"><a href=https://photographylife.com/portrait-photography><span class=pl-tutorials-title>Portrait Photography</span></a></div><div class="pl-tutorials-street pl-tutorials-bg"><a href=https://photographylife.com/what-is-street-photography><span class=pl-tutorials-title>Street Photography</span></a></div><div class="pl-tutorials-advanced pl-tutorials-bg"><a href=https://photographylife.com/photography-videos><span class=pl-tutorials-title>Photography Videos</span></a></div></div></div></div></section><section id=text-7 class="widget widget_text"><div class=widget-wrap><h3 class="widgettitle widget-title">Support Us</h3><div class=textwidget><p><a href="https://www.bhphotovideo.com/c/buy/Great-Deals/ci/16478/N/4280521071+30/view/GRID?BI=5562&amp;KW=&amp;KBID=6400" target=_blank rel="noopener noreferrer nofollow sponsored"><img class=lazy loading=lazy src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20300%20250'%3E%3C/svg%3E" data-src=https://photographylife.com/wp-content/uploads/2019/07/BH-Banner.jpg alt="B&amp;H Photo Video Banner" width=300 height=250 border=0></a></p></div></div></section><section id=pl_sidebar_bottom_widget-3 class="widget widget_text"><div class=widget-wrap><div align=center id=PhotographyLife_300x600_300x250_160x600_Sidebar_BTF> <script data-cfasync=false>freestar.config.enabled_slots.push({placementName:"PhotographyLife_300x600_300x250_160x600_Sidebar_BTF",slotId:"PhotographyLife_300x600_300x250_160x600_Sidebar_BTF"});</script> </div></div></section></aside></div></div><div class=footer-widgets><h2 class="genesis-sidebar-title screen-reader-text">Footer</h2><div class="widget-area footer-widgets-1 footer-widget-area"><section id=nav_menu-2 class="widget widget_nav_menu"><div class=widget-wrap><h3 class="widgettitle widget-title">Site Menu</h3><div class=menu-footer-one-container><ul id=menu-footer-one class=menu><li id=menu-item-241986 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241986"><a href=https://photographylife.com/about-us>About Us</a></li> <li id=menu-item-140497 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-140497"><a href=https://photographylife.com/learn-photography>Beginner Photography</a></li> <li id=menu-item-124476 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-124476"><a href=/lenses>Lens Database</a></li> <li id=menu-item-241977 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241977"><a href=/lens-index>Lens Index</a></li> <li id=menu-item-124477 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-124477"><a href=/photo-spots>Photo Spots</a></li> <li id=menu-item-152204 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152204"><a href=/pl-search>Search</a></li> <li id=menu-item-241985 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241985"><a href=https://forum.photographylife.com>Forum</a></li></ul></div></div></section></div><div class="widget-area footer-widgets-2 footer-widget-area"><section id=nav_menu-3 class="widget widget_nav_menu"><div class=widget-wrap><h3 class="widgettitle widget-title">Reviews</h3><div class=menu-footer-two-container><ul id=menu-footer-two class=menu><li id=menu-item-241978 class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241978"><a href=/reviews>Reviews Archive</a></li> <li id=menu-item-124478 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-124478"><a href=https://photographylife.com/camera-reviews>Camera Reviews</a></li> <li id=menu-item-124479 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-124479"><a href=https://photographylife.com/lens-reviews>Lens Reviews</a></li> <li id=menu-item-124480 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-124480"><a href=https://photographylife.com/other-gear-reviews>Other Gear Reviews</a></li></ul></div></div></section></div><div class="widget-area footer-widgets-3 footer-widget-area"><section id=nav_menu-4 class="widget widget_nav_menu"><div class=widget-wrap><h3 class="widgettitle widget-title">More</h3><div class=menu-footer-three-container><ul id=menu-footer-three class=menu><li id=menu-item-241980 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241980"><a href=https://photographylife.com/contact-us>Contact Us</a></li> <li id=menu-item-241981 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241981"><a href=https://photographylife.com/subscribe>Subscribe</a></li> <li id=menu-item-241982 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241982"><a href=https://photographylife.com/workshops>Workshops</a></li> <li id=menu-item-241983 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241983"><a href=https://photographylife.com/support-us>Support Us</a></li> <li id=menu-item-241984 class="menu-item menu-item-type-post_type menu-item-object-page menu-item-241984"><a href=https://photographylife.com/submit-content>Submit Content</a></li></ul></div></div></section></div></div><footer class=site-footer><p><div class=wrap-inside><div class=creds>Copyright &#x000A9;&nbsp;2021 · Photography Life</div></div></p></footer></div></div><div id=wpd-editor-source-code-wrapper-bg></div><div id=wpd-editor-source-code-wrapper><textarea id=wpd-editor-source-code></textarea><button id=wpd-insert-source-code>Insert</button><input type=hidden id=wpd-editor-uid></div><link rel=stylesheet id=yikes-inc-easy-mailchimp-public-styles-css  href=https://photographylife.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/css/yikes-inc-easy-mailchimp-extender-public.min.css type=text/css media=all><link rel=stylesheet id=yikes-mailchimp-eu-frontend-compliance-styles-css  href=https://photographylife.com/wp-content/plugins/eu-opt-in-compliance-for-mailchimp/includes/css/yikes-mailchimp-eu-law-extension-frontend.min.css type=text/css media=all> <script src=https://photographylife.com/wp-content/plugins/wpdiscuz/assets/third-party/wpdccjs/wpdcc.js id=wpdiscuz-cookie-js-js></script> <script src=https://photographylife.com/wp-content/plugins/wpdiscuz/assets/third-party/autogrow/jquery.autogrowtextarea.min.js id=autogrowtextarea-js-js></script> <script id=wpdiscuz-ajax-js-js-extra>var wpdiscuzAjaxObj={"wc_hide_replies_text":"Hide Replies","wc_show_replies_text":"View Replies","wc_msg_required_fields":"Please fill out required fields","wc_invalid_field":"Some of field value is invalid","wc_error_empty_text":"please fill out this field to comment","wc_error_url_text":"url is invalid","wc_error_email_text":"email address is invalid","wc_invalid_captcha":"Invalid Captcha Code","wc_login_to_vote":"You Must Be Logged In To Vote","wc_deny_voting_from_same_ip":"You are not allowed to vote for this comment","wc_self_vote":"You cannot vote for your comment","wc_vote_only_one_time":"You've already voted for this comment","wc_voting_error":"Voting Error","wc_comment_edit_not_possible":"Sorry, this comment is no longer possible to edit","wc_comment_not_updated":"Sorry, the comment was not updated","wc_comment_not_edited":"You've not made any changes","wc_msg_input_min_length":"Input is too short","wc_msg_input_max_length":"Input is too long","wc_spoiler_title":"Spoiler Title","wc_cannot_rate_again":"You cannot rate again","wc_not_allowed_to_rate":"You're not allowed to rate here","wc_follow_user":"Follow this user","wc_unfollow_user":"Unfollow this user","wc_follow_success":"You started following this comment author","wc_follow_canceled":"You stopped following this comment author.","wc_follow_email_confirm":"Please check your email and confirm the user following request.","wc_follow_email_confirm_fail":"Sorry, we couldn't send confirmation email.","wc_follow_login_to_follow":"Please login to follow users.","wc_follow_impossible":"We are sorry, but you can't follow this user.","wc_follow_not_added":"Following failed. Please try again later.","is_user_logged_in":"","commentListLoadType":"0","commentListUpdateType":"0","commentListUpdateTimer":"30","liveUpdateGuests":"0","wordpressThreadCommentsDepth":"10","wordpressIsPaginate":"","commentTextMaxLength":"0","replyTextMaxLength":"0","commentTextMinLength":"1","replyTextMinLength":"1","storeCommenterData":"100000","socialLoginAgreementCheckbox":"0","enableFbLogin":"0","fbUseOAuth2":"0","enableFbShare":"0","facebookAppID":"","facebookUseOAuth2":"0","enableGoogleLogin":"0","googleClientID":"","googleClientSecret":"","cookiehash":"a527aee3e1ba36fa1b937925d29b39ee","isLoadOnlyParentComments":"0","scrollToComment":"0","commentFormView":"collapsed","enableDropAnimation":"0","isNativeAjaxEnabled":"0","enableBubble":"0","bubbleLiveUpdate":"0","bubbleHintTimeout":"45","bubbleHintHideTimeout":"10","cookieHideBubbleHint":"wpdiscuz_hide_bubble_hint","bubbleShowNewCommentMessage":"0","bubbleLocation":"content_left","firstLoadWithAjax":"0","wc_copied_to_clipboard":"Copied to clipboard!","inlineFeedbackAttractionType":"blink","loadRichEditor":"0","wpDiscuzReCaptchaSK":"6LemxOoSAAAAAHL-pieRnyL0az6uijgbM7f2hoSA","wpDiscuzReCaptchaTheme":"light","wpDiscuzReCaptchaVersion":"2.0","wc_captcha_show_for_guest":"0","wc_captcha_show_for_members":"0","wpDiscuzIsShowOnSubscribeForm":"0","wmuEnabled":"0","wmuInput":"wmu_files","wmuMaxFileCount":"1","wmuMaxFileSize":"2097152","wmuPostMaxSize":"134217728","wmuIsLightbox":"1","wmuMimeTypes":{"jpg":"image\/jpeg","jpeg":"image\/jpeg","jpe":"image\/jpeg","gif":"image\/gif","png":"image\/png","bmp":"image\/bmp","tiff":"image\/tiff","tif":"image\/tiff","ico":"image\/x-icon"},"wmuPhraseConfirmDelete":"Are you sure you want to delete this attachment?","wmuPhraseNotAllowedFile":"Not allowed file type","wmuPhraseMaxFileCount":"Maximum number of uploaded files is 1","wmuPhraseMaxFileSize":"Maximum upload file size is 2MB","wmuPhrasePostMaxSize":"Maximum post size is 128MB","msgEmptyFile":"File is empty. Please upload something more substantial. This error could also be caused by uploads being disabled in your php.ini or by post_max_size being defined as smaller than upload_max_filesize in php.ini.","msgPostIdNotExists":"Post ID not exists","msgUploadingNotAllowed":"Sorry, uploading not allowed for this post","msgPermissionDenied":"You do not have sufficient permissions to perform this action","wmuSecurity":"b687bfe52e","wmuKeyImages":"images","wmuSingleImageWidth":"auto","wmuSingleImageHeight":"200","version":"7.3.3","wc_post_id":"242854","isCookiesEnabled":"1","loadLastCommentId":"0","dataFilterCallbacks":[],"phraseFilters":[],"scrollSize":"32","is_email_field_required":"1","url":"https:\/\/photographylife.com\/wp-admin\/admin-ajax.php","customAjaxUrl":"https:\/\/photographylife.com\/wp-content\/plugins\/wpdiscuz\/utils\/ajax\/wpdiscuz-ajax.php","bubbleUpdateUrl":"https:\/\/photographylife.com\/wp-json\/wpdiscuz\/v1\/update","restNonce":"d8c41a662e"};</script> <script src=https://photographylife.com/wp-content/plugins/wpdiscuz/assets/js/wpdiscuz.min.js id=wpdiscuz-ajax-js-js></script> <script src=https://photographylife.com/wp-includes/js/comment-reply.min.js id=comment-reply-js></script> <script id=q2w3_fixed_widget-js-extra>var q2w3_sidebar_options=[{"sidebar":"sidebar","margin_top":10,"margin_bottom":0,"stop_id":"","screen_max_width":0,"screen_max_height":0,"width_inherit":true,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["pl_sidebar_bottom_widget-3"]}];</script> <script id=news-responsive-menus-js-extra>var genesis_responsive_menu={"mainMenu":"","subMenu":"","menuClasses":{"combine":[".nav-secondary",".nav-primary",".nav-header"]}};</script> <script src=https://photographylife.com/wp-content/themes/mainr/js/jquery.plfb.min.js id=fancybox-script-js></script> <script src=https://photographylife.com/wp-content/plugins/eu-opt-in-compliance-for-mailchimp/includes/js/yikes-mailchimp-front-end-form-functions.min.js id=yikes-mailchimp-eu-frontend-compliance-scripts-js></script> <script id=yikes-easy-mc-ajax-js-extra>var yikes_mailchimp_ajax={"ajax_url":"https:\/\/photographylife.com\/wp-admin\/admin-ajax.php","page_data":"242854","interest_group_checkbox_error":"This field is required.","preloader_url":"https:\/\/photographylife.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/ripple.svg","loading_dots":"https:\/\/photographylife.com\/wp-content\/plugins\/yikes-inc-easy-mailchimp-extender\/includes\/images\/bars.svg","ajax_security_nonce":"5051643a3f","feedback_message_placement":"before"};</script> <script src=https://photographylife.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/yikes-mc-ajax-forms.min.js id=yikes-easy-mc-ajax-js></script> <script id=form-submission-helpers-js-extra>var form_submission_helpers={"ajax_url":"https:\/\/photographylife.com\/wp-admin\/admin-ajax.php","preloader_url":"https:\/\/photographylife.com\/wp-admin\/images\/wpspin_light.gif","countries_with_zip":{"US":"US","GB":"GB","CA":"CA","IE":"IE","CN":"CN","IN":"IN","AU":"AU","BR":"BR","MX":"MX","IT":"IT","NZ":"NZ","JP":"JP","FR":"FR","GR":"GR","DE":"DE","NL":"NL","PT":"PT","ES":"ES"},"page_data":"242854"};</script> <script src=https://photographylife.com/wp-content/plugins/yikes-inc-easy-mailchimp-extender/public/js/form-submission-helpers.min.js id=form-submission-helpers-js></script> <script src=https://stats.wp.com/e-202140.js defer></script> <script>_stq=window._stq||[];_stq.push(['view',{v:'ext',j:'1:10.2',blog:'4702185',post:'242854',tz:'-6',srv:'photographylife.com'}]);_stq.push(['clickTrackerInit','4702185','242854']);</script> <style>img.lazy{min-height:1px}</style><script>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</script><script async src=https://photographylife.com/wp-content/cache/minify/f48b3.default.include-footer.6010fd.js></script> </body></html>